Skip to content
Navigation Menu
Sign in
Products
Platform
GitHub
Repository hosting, code review, and collaboration
Copilot
AI coding agent for tasks, projects and automated work
Build & Ship
Actions
CI/CD and automation
Code Quality
Quality analysis, fixes, and enforcement
Codespaces
Cloud development environments
Secure
Code Security
Vulnerability detection and remediation
Secret Protection
Secret scanning and leak prevention
All Features
Developers
Learn
Documentation
Training
Certifications
Build
Build with Copilot
Customize Copilot
Integrations
Explore
Trending repos
GitHub Sponsors
Developer articles
Changelog
Changelog
Your source for the latest features, improvements, and fixes across GitHub products, all in one place.
Businesses
By Stage
Enterprises
Team
Startups
Nonprofits
By Industry
Healthcare
Financial services
Manufacturing
Government
See all industries
Evaluate GitHub
Why GitHub
Customer Stories
Business insights
Trust Center
Add-ons
GitHub Advanced Security
Enterprise-grade code security
Copilot for business
Enterprise-grade AI features
Premium Support
Enterprise-grade 24/7 support
Resources
Learn & Connect
Documentation
Resource center
Blog
Events & webinars
Community Forum
Customer Stories
Integrations
Support
Customer support
Training
GitHub Status
Company
About
Partners
Changelog
GitHub Universe
GitHub Universe
The event for developers, by developers — talks, workshops, and what’s next for GitHub.
Pricing
Search
/
Sign in
Sign up
Appearance settings
You signed in with another tab or window.
Reload
to refresh your session.
You signed out in another tab or window.
Reload
to refresh your session.
You switched accounts on another tab or window.
Reload
to refresh your session.
Dismiss alert
{{ message }}
apache
httpcomponents-core
Repository navigation
Code
Pull requests
9
(9)
Actions
Projects
Security and quality
Insights
More
items
Actions: apache/httpcomponents-core
Actions
All workflows
Workflows
CodeQL
CodeQL
Dependabot Updates
Dependabot Updates
Dependency Review
Dependency Review
Java CI
Java CI
Show more workflows...
Management
Caches
Lockfile
CodeQL
CodeQL
Actions
Loading...
Loading
Sorry, something went wrong.
Uh oh!
There was an error while loading.
Please reload this page
.
will be ignored since log searching is not yet available
Show workflow options
Create status badge
Create status badge
Loading
Uh oh!
There was an error while loading.
Please reload this page
.
codeql-analysis.yml
will be ignored since log searching is not yet available
811 workflow runs
811 workflow runs
Event
Filter by Event
Sorry, something went wrong.
Filter
Loading
Sorry, something went wrong.
No matching events.
Status
Filter by Status
Sorry, something went wrong.
Filter
Loading
Sorry, something went wrong.
No matching statuses.
Branch
Filter by Branch
Sorry, something went wrong.
Filter
Loading
Sorry, something went wrong.
No matching branches.
Actor
Filter by Actor
Sorry, something went wrong.
Filter
Loading
Sorry, something went wrong.
No matching users.
HTTPCLIENT-2437: LaxConnPool fails expired lease requests queued behi…
CodeQL
#1654:
Commit
57428d2
pushed by
ok2c
9m 47s
master
master
9m 47s
View workflow file
HTTPCLIENT-2437: LaxConnPool fails expired lease requests queued behind a live one
CodeQL
#1653:
Pull request
#738
opened by
shinseongsu
22m 16s
shinseongsu:lax-pool-expire-pending
shinseongsu:lax-pool-expire-pending
22m 16s
View #738
View workflow file
Javadoc: EntityUtils updates to match the code.
CodeQL
#1652:
Commit
b752e4c
pushed by
garydgregory
6m 41s
master
master
6m 41s
View workflow file
Do not stop the listening reactor when accept() fails
CodeQL
#1651:
Pull request
#730
synchronize by
arturobernalg
35m 48s
arturobernalg:listener-survives-accept-failure
arturobernalg:listener-survives-accept-failure
35m 48s
View #730
View workflow file
Bump the all group across 1 directory with 2 updates
CodeQL
#1650:
Pull request
#737
opened by
dependabot
Bot
14m 47s
dependabot/maven/all-880961e727
dependabot/maven/all-880961e727
14m 47s
View #737
View workflow file
Notify the callbacks of lease requests failed by StrictConnPool#enumA…
CodeQL
#1649:
Commit
9983b03
pushed by
arturobernalg
3m 16s
master
master
3m 16s
View workflow file
Notify the callbacks of lease requests failed by StrictConnPool eviction
CodeQL
#1648:
Pull request
#735
opened by
arturobernalg
2m 39s
arturobernalg:pending-requests-callbacks
arturobernalg:pending-requests-callbacks
2m 39s
View #735
View workflow file
Do not stop the listening reactor when accept() fails
CodeQL
#1647:
Pull request
#730
synchronize by
arturobernalg
2m 14s
arturobernalg:listener-survives-accept-failure
arturobernalg:listener-survives-accept-failure
2m 14s
View #730
View workflow file
Do not stop the listening reactor when accept() fails
CodeQL
#1646:
Pull request
#730
synchronize by
arturobernalg
2m 22s
arturobernalg:listener-survives-accept-failure
arturobernalg:listener-survives-accept-failure
2m 22s
View #730
View workflow file
Do not stop the listening reactor when accept() fails
CodeQL
#1645:
Pull request
#730
synchronize by
arturobernalg
3m 11s
arturobernalg:listener-survives-accept-failure
arturobernalg:listener-survives-accept-failure
3m 11s
View #730
View workflow file
Bump the all group with 4 updates
CodeQL
#1644:
Pull request
#734
opened by
dependabot
Bot
3m 3s
dependabot/maven/all-6d48528587
dependabot/maven/all-6d48528587
3m 3s
View #734
View workflow file
Do not stop the listening reactor when accept() fails
CodeQL
#1643:
Pull request
#730
synchronize by
arturobernalg
3m 17s
arturobernalg:listener-survives-accept-failure
arturobernalg:listener-survives-accept-failure
3m 17s
View #730
View workflow file
RFC 9113: limit the number of pending control frames
CodeQL
#1642:
Pull request
#731
synchronize by
arturobernalg
3m 13s
arturobernalg:h2-max-control-frames
arturobernalg:h2-max-control-frames
3m 13s
View #731
View workflow file
RFC 9112: reject messages with both Transfer-Encoding and Content-Length
CodeQL
#1641:
Pull request
#733
opened by
arturobernalg
2m 55s
arturobernalg:te-and-cl
arturobernalg:te-and-cl
2m 55s
View #733
View workflow file
RFC 9110: reject header field names that are not a token
CodeQL
#1640:
Pull request
#732
opened by
arturobernalg
3m 4s
arturobernalg:header-name-token
arturobernalg:header-name-token
3m 4s
View #732
View workflow file
RFC 9113: limit the number of pending control frames
CodeQL
#1639:
Pull request
#731
opened by
arturobernalg
2m 33s
arturobernalg:h2-max-control-frames
arturobernalg:h2-max-control-frames
2m 33s
View #731
View workflow file
Do not stop the listening reactor when accept() fails
CodeQL
#1638:
Pull request
#730
opened by
arturobernalg
3m 2s
arturobernalg:listener-survives-accept-failure
arturobernalg:listener-survives-accept-failure
3m 2s
View #730
View workflow file
RFC 9112: reject signed chunk sizes and Content-Length values
CodeQL
#1637:
Commit
450ef92
pushed by
arturobernalg
2m 26s
master
master
2m 26s
View workflow file
RFC 9112: reject signed chunk sizes and Content-Length values
CodeQL
#1636:
Pull request
#729
synchronize by
arturobernalg
2m 8s
arturobernalg:chunk-size-digits
arturobernalg:chunk-size-digits
2m 8s
View #729
View workflow file
RFC 9112: reject signed chunk sizes and Content-Length values
CodeQL
#1635:
Pull request
#729
synchronize by
arturobernalg
2m 58s
arturobernalg:chunk-size-digits
arturobernalg:chunk-size-digits
2m 58s
View #729
View workflow file
RFC 9112: reject signed chunk sizes and Content-Length values
CodeQL
#1634:
Pull request
#729
opened by
arturobernalg
3m 13s
arturobernalg:chunk-size-digits
arturobernalg:chunk-size-digits
3m 13s
View #729
View workflow file
bug-fix: URIBuilder: Corrected optimization of path ending with '..' …
CodeQL
#1633:
Commit
d68d4f5
pushed by
ok2c
3m 18s
master
master
3m 18s
View workflow file
bug-fix: URIBuilder: Corrected optimization of path ending with '..' or '.' segment
CodeQL
#1632:
Pull request
#728
opened by
ok2c
2m 29s
ok2c:fix_path_optimization
ok2c:fix_path_optimization
2m 29s
View #728
View workflow file
PathSegmentCodec: added #splitPath method, added #formatSegments meth…
CodeQL
#1631:
Commit
901455a
pushed by
ok2c
3m 42s
master
master
3m 42s
View workflow file
PathSegmentCodec: added #splitPath method and #formatSegments method …
CodeQL
#1630:
Commit
e93cfff
pushed by
ok2c
3m 15s
master
master
3m 15s
View workflow file
Previous
1
2
3
4
5
…
32
33
Next
You can’t perform that action at this time.